All iOS-app users need to update the Landax App within December 6. 2023
Incident Report for EG Landax
Resolved
This incident has been resolved.
Posted Jan 04, 2024 - 14:28 CET
Update
We are continuing to work on a fix for this issue.
Posted Dec 04, 2023 - 10:45 CET
Update
All iOS-app users need to update the Landax App within December 6. 2023
Posted Dec 01, 2023 - 10:28 CET
Update
All iOS-app users need to update the Landax App within December 6. 2023
Posted Dec 01, 2023 - 09:24 CET
Identified
Working with a solution
Posted Dec 01, 2023 - 09:12 CET
Investigating
We are currently investigating this issue.
Posted Dec 01, 2023 - 09:10 CET
This incident affected: Mobile Applications.