Data missing from dashboard
Incident Report for EG Landax
Resolved
This incident has been resolved.
Posted Jun 26, 2023 - 18:43 CEST
Update
We are continuing to investigate this issue.
Posted Jun 26, 2023 - 18:42 CEST
Investigating
Several users are reporting data not being visible on dashboard in web application.
Posted Jun 26, 2023 - 18:15 CEST
This incident affected: Web Application.