Some problems with the search engines.

Incident Report for EG Landax

Resolved

This incident has been resolved.
Posted Aug 11, 2025 - 12:08 CEST

Investigating

Some customers are experiencing some disruptions related to the search engine
Posted Aug 11, 2025 - 09:05 CEST
This incident affected: Search.